XpressMail error S7218

For the past few days, I haven’t been able to get Cingular XpressMail (powered by Seven) on my Treo 650 to fetch my work email. It fetches my Yahoo email with no problems but when I try to check my corporate email, it seems to successfully connect to the server, but then while syncing changes, it fails with “Error S7218: Please click OK and try again.”. It’s been doing this for a few days. The PC software is running and seems to have no problem connecting to my IMAP server. Any ideas?

Update 2005-06-25: I took Dan’s advice and deleted the Palm client and reinstalled. Now I get error S7203 while it is trying to negotiate with the server to generate the encryption keys.

Update 2005-06-27: I tried upgrading the desktop client on my work PC from 6.3.1.442 to 6.3.8.645 and that didn’t help. I tried reinstalling the Palm app and that did nothing. Then figuring that maybe I have some bad preferences, I deleted the Palm app and reinstalled it. Now I’m getting “Error S7123: A server operation caused an error. If the problem persists, contact support.”. So I retried 2 or 3 times and then finally I got it to work at least once. Yay!

Boxwave adBoxwave ad

10 thoughts on “XpressMail error S7218

  1. help!! i’m having the same problems with my 650… i can get my personal email but not my office email. i have been getting error s7123.. what is desktop client???

    i did a hard reset but did not work. even my inbox to go doesn’t work with my work email…and again my personal does! our IT guy cannot figure it out… thanks….if this problem continues i’m trashing this 650 and going with a blackberry!!!!!

  2. Desktop client is what you run on your Windows PC if you’re using XpressMail Personal Edition. Perhaps you have the Enterprise Edition, in which case the software runs on your IT Department servers instead?

    XpressMail is pretty finicky. When I get these weird errors what usually helps is to delete the client off my Treo and then reinstall it again.

    I’m not really using XpressMail anymore now though because my IT Department doesn’t support it (only GoodLink) and I traded my Windows desktop for a PowerBook, so I have no Windows machine to run the Personal Edition desktop client on now.

  3. Struggling with it on my Audiovox SMT 5600 and have spent about 8 hours with six different techs.

    I find that I need to “disconnect and then connect” xprerss on my desktop during the day.

    Direct phone number to Data support at Cingular 866-490-2666

  4. The joke reads as follows:

    Here is what the SMEs advised me to have you try…..

    “Since the customer is using a POP3 account, he needs to go into the XMPE web access account and correct the account settings for his POP3 account (log into account for error). Switch the account from Personal Edition to the MATRIX POP3 account. From there, the device client will connect to the integrated POP account instead of trying to connect to the desktop.”

    They also added the following reason for loss of connectivity:

    “The other problem is that he is losing desktop connectivity because the desktop client is designed to function solely with Exchange/Domino servers. If the customer uses the desktop software without a secure personal server running, the desktop software will not work as designed and the device will occasionally lose connectivity; since there isn’t a MAPI involved that pushes the commands, the customer will run into this issue.”

    Please try these fixes and let me know what happens.

  5. I am having the same problem. I am running palm client version 6.3.8.10. When I looked at the phone info, under the menu on xpress mail palm, it had garbage for my telephone number.

    I re-registered the device and now the error is gone.

    I was receiving the S7203 error.

    Cheers.

  6. I was getting the same error and wanting to take the pathway of least resistance 😉 I tried disconecting and reconnecting my desktop Express Mail client. Now it works just fine. Of course if I am on the road this is not a viable solution! 🙁

  7. I had same problem w/ Sync: S7218 error. Disconnected and reconnected xpress mail desktop agent and now it works. I use Netmeeting to access my PC running Xpressmail remotely.

  8. I had the same problem with my mpx 220 (cingular at&t gprs). Although everything looked good, it appears my certs were stale, even after refreshing both the client and the handset. To update the user needs to hit xm settings, account information, menu, new user.
    Have fun.

  9. I had the same problem, I updated the ROM version on my treo650 and started to receive this error. to fix it, I deleted the app and all data from my phone. Re-installed the app on my phone, wnet through the setup and it worked.

  10. I have a cingular 8125 I’m getting error message s7109. I am trying to register my phone for 100’s time, maybe 200’s time who’s counting. Help!

Leave a Reply

Your email address will not be published.