Working around an mzscheme install error in Ubuntu

Here’s a minor fix for an mzscheme/slib snafu on Ubuntu Edgy Eft.

I was trying to install mzscheme on my Ubuntu Edgy system and it failed with a strange error:

marc@tbird:~/scheme$ sudo aptitude install slib
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Setting up mzscheme (352-1) ...
Cataloging SLIB routines...
path->string: expects argument of type ; given "/usr/share/slib"
dpkg: error processing mzscheme (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 mzscheme
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up mzscheme (352-1) ...
Cataloging SLIB routines...
path->string: expects argument of type ; given "/usr/share/slib"
dpkg: error processing mzscheme (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 mzscheme

I was able to fix this problem by removing the slib package:

marc@tbird:~$ sudo aptitude remove slib
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  gnucash guile-1.6-slib
The following packages will be REMOVED:
  slib
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 3936kB will be freed.
The following packages have unmet dependencies:
  gnucash: Depends: slib (>= 3a2-5) but it is not installable
  guile-1.6-slib: Depends: slib (>= 3a2-3) but it is not installable
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
g-wrap
gnucash
guile-1.6-slib

Leave the following dependencies unresolved:
gnucash-common recommends gnucash (>= 2.0.1-3ubuntu3)
Score is -1201

Accept this solution? [Y/n/q/?]
The following packages will be automatically REMOVED:
  g-wrap gnucash guile-1.6-slib
The following packages will be REMOVED:
  g-wrap gnucash guile-1.6-slib slib
0 packages upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 10.8MB will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
(Reading database ... 255882 files and directories currently installed.)
Removing gnucash ...
Removing g-wrap ...
Removing guile-1.6-slib ...
Removing slib ...
Setting up mzscheme (352-1) ...

Starting web server: mzserver ... done.

marc@tbird:~$ mzscheme
Welcome to MzScheme version 352, Copyright (c) 2004-2006 PLT Scheme Inc.
> (+ 1 2)
3

And then afterwards, I was able to reinstall GnuCash.

Leave a Reply

Your email address will not be published.