Thoughts on the Apogee Duet

Apogee Duet FireWire Interface

My Apogee Duet Firewire audio interface arrived.


  • It looks great. It’s bigger than I thought it would be, but still a nice size. With it’s simple controls and silver, rounded body, it looks right at home with my MacBook Pro.
  • Ease of set up. No problems. Downloaded the latest software package from Apogee’s site, installed it, rebooted, and then plugged in the Duet. A dialog came right up asking whether to use it as the default audio device and Logic Express found it with no problems either.
  • Ease of use. I worried about it only having one knob, but it seems like that’s all I need. Pressing the knob toggle between the two inputs and the outputs which is quick and easy. Having meters and clip indicators on the unit is really nice when adjusting levels. Another nice feature is that adjustments on the unit are mirrored in a transparent popup on the Mac display, which is a nice touch.
  • Sound. Very pleased. Being the pessimist that I am and not being a person with “golden ears”, I wasn’t expecting to hear anything really noticeable, but I was pleasantly surprised. The most noticeable thing was the lack of apparent noise when there’s no signal and listening with headphones. It’s so dead quiet that I wondered several times if it was still in the signal path. And music played through it sounds great too.
  • Crashes. Unfortunately, OS X did crash once when I plugged it in, but in fairness, this is almost certainly Apple’s fault, since it also happened with a PreSonus Firebox (see this post) (and I’ve seen reports of it happening with the Inspire 1394 as well). C’mon Apple – fix this. This is OS X; not Windows. This reminds me of Windows 98 crashing on Bill Gates when he plugged in a scanner at Comdex 1998.

Logic bug: Creating Apple Loops from a region

While following the exercise “Creating Blue Apple Loops” on page 262 of “Logic Pro 8 and Logic Express 8” by David Nahmani, I was running into some trouble.

1. Open Logic project file: “07 New Day”.
2. Drag the Marquee tool (Command-click tool) over the High Arpeggio region from bar 5 to bar 7. Verify that before releasing the mouse button, the help tag reads “5 1 1 1 7 1 1 1”, indicating that Marquee selection goes from bar 5 to bar 7 and is thus 2 bars in length.
3. Click the Marquee selection with the Pointer tool to create a new region that should be exactly 2 bars in length.
4. In the Arrange area’s local menu bar, choose Region > Add to Apple Loops Library.

Expected Results:
The dialog should offer the choice of “Loop” or “One-shot”.

Actual Results:
The choice of “Loop” or “One-shot” is grayed out.

According to the book and, this graying out is a symptom of having a region that is not a whole number of bars in length, but this region seems to be exactly 2 bars in length as far as I can tell.

I posted about this on the Logic Pro Help forums (run by Mr. Nahmani; not Apple) and Mr. Nahmani kindly pointed me to an earlier thread that explains the problem and how to work around it. Basically, the bug is that the help tag is indicating that the region is 2 bars in length, when in fact, it’s actually a bit shorter. The remedy is to tweak the region a bit to make it shorter and then to make it exactly 2 bars in length.

I hope this helps other folks who run into this problem. And I hope Apple fixes this bug.

Finished “Logic Pro 8 and Logic Express 8” book

I had been working through the exercises in “Logic Pro 8 and Logic Express 8” by David Nahmani lately, mostly while on the shuttle bus to and from work (and yesterday on the VTA light rail on the way to SD West). I completed the last lesson last night, which involved adding music and sound effects to a video.

The book is excellent and I learned a lot about using Logic from it. Now that I’m done with this book, I’m going to buy “Logic Pro 8: Beyond the Basics” by David Dvorin and work through that.

While on the topic of Logic, I should mention that the author of the book, David Nahmani, has some nice Logic forums at

Audio interfaces

Ah, what audio interface to buy for doing some simple 2 channel recordings into my MacBook Pro?

There’s the Presonus Firebox ($300), which I borrowed from a friend. Sounds pretty good, although the preamp gain (45 dB) is not stellar and no inserts for sticking something like a compressor. It seems to work pretty well in Leopard, although it sometimes disappears and I’ve had to replug it or reboot the computer to get it to show up again. Bus-powered, but you have to plug it in when you first connect it; otherwise it flashes and makes a loud, disturbing clicking sound. No meters; just clip LEDs. Most annoyingly, sometimes when I plug it into my MacBook Pro with OS X 10.5.2, I get a kernel panic:

      Kernel loadable modules in backtrace (with dependencies):>0x5b493fff

Presonus has a higher-end model called the FireStudio Project, which looks nice on paper. Goes for $500. More channels (more than I need). Better preamp gain (60 dB vs. 45 dB for the Firebox) and dynamic range on the A/D converters (114 dB vs. 108 dB for the Firebox). Has inserts and meters and an interesting-sounding software bundle. Unfortunately, it seems to have a lot of problems with Leopard and/or the new Firewire chipset on newer Macs:

Another option is the Apogee Duet ($500). I can’t find reliable-looking specs on the preamps or A/D converters (BSW claims the preamps have 75 dB of gain), but there seems to be a favorable impression of the sound quality (similar to its big brother, the $1900+ Ensemble) and the usability and aesthetics. Haven’t heard any complaints about Leopard or general stability. It looks pretty nice and even has meters with 7 LEDs. No inserts though. And it’s Mac only and Core Audio only. I have a Mac, so that’s not too bad, though it might be nice to have something that works with a PC in case I’m out of the house and jamming with other folks.

XO Wave Free

While cruising freshmeat the other day, I stumbled upon a free multi-track digital audio program called XO Wave.

I played with it. I didn’t care for the UI, which was very un-Mac-like and looked like it might’ve resulted from porting the app from another platform. I also found the latency to be pretty poor (this is with a Santa Rosa MacBook Pro and an M-Audio MobilePre USB audio interface). I tried playing with some of the settings like the size of the playback buffers, but to no avail.

Since I already own Logic Express, I gave up rather quickly on XO Wave and used Logic Express, with much better results.